Back to overview
Degraded

Email Service Interruption

Sep 03 at 01:37pm NZST
Affected services
WPhost Mail Platform
WPhost Mail Platform
WebMail

Resolved
Sep 03 at 04:36pm NZST

We are pleased to inform you that the affected services are now up and running.

As a precaution, we will continue to monitor the server closely to ensure stability and performance. If you encounter any further issues, please don’t hesitate to contact our support team.

Thank you for your patience and understanding.

Created
Sep 03 at 01:37pm NZST

We are currently experiencing technical difficulties impacting email services.

Our engineering team is actively working on this matter to resolve as swiftly as possible. We sincerely appreciate your patience and understanding during this time.