Back to overview
Degraded
Email Service Interruption
Sep 08 at 07:36am NZST
Affected services
WPhost Mail Platform
WPhost Mail Platform
WebMail
Resolved
Sep 08 at 08:46am NZST
We're seeing mail now flowing through to mailboxes and the mail queue processing.
We continue to monitor this situation closely.
Affected services
Created
Sep 08 at 07:36am NZST
We are currently experiencing technical difficulties impacting email services.
Our engineering team is investigating.
We will provide further updates as new information becomes available.
Affected services